Issue between FFastrans service and API

This forum is ONLY for the new FFAStrans 1.0.0 beta versions. Any bug and issue reporting regarding the beta MUST be posted here.
emcodem
Posts: 656
Joined: Wed Sep 19, 2018 8:11 am

Re: Issue between FFastrans service and API

Post by emcodem » Fri Nov 22, 2019 8:24 am

@admin
Benjamin already sent me his cache directory. For me it looked exactly like Benjamin said: the services just stopped (yes, rest_service and exe_manager).

The log lines of interest at the time when the service breaks are in exe_log (look at bottom):

Code: Select all


=EXE=> 2019/10/22 11:51:38.412 executing job: \\ctvf2nas\NAS\FFAStrans0.9.4\Processors\.cache\tickets\x20191022-115138-171-5AF54911FC19_20180927190152~loc~CTVF2WORKFLOWA~20191022-115102-433-1056079DBB3E.ini with PID: 14924
=EXE=> 2019/10/22 11:51:44.976 service with PID: 9716 is OK.
=EXE=> 2019/10/22 11:51:46.216 executing job: \\ctvf2nas\NAS\FFAStrans0.9.4\Processors\.cache\tickets\x20191022-115146-054-8C1023380E3A_20180306185223~loc~CTVF2WORKFLOWA~20191022-114736-247-FBB506074619.ini with PID: 12800
=EXE=> 2019/10/22 11:51:46.772 executing job: \\ctvf2nas\NAS\FFAStrans0.9.4\Processors\.cache\tickets\x20191022-115146-583-5CBCB0CA200D_20180927190152~loc~CTVF2WORKFLOWA~20191022-114740-146-4A9234D5EBEF.ini with PID: 556
=EXE=> 2019/10/22 11:51:49.726 executing job: \\ctvf2nas\NAS\FFAStrans0.9.4\Processors\.cache\tickets\x20191022-115149-607-CC5063155C59_20180306185223~loc~CTVF2WORKFLOWA~20191022-114752-948-A98DE01D6DCA.ini with PID: 7248
=EXE=> 2019/10/22 11:51:50.334 executing job: \\ctvf2nas\NAS\FFAStrans0.9.4\Processors\.cache\tickets\x20191022-115150-130-E002C3463FA1_20180306185223~loc~CTVF2WORKFLOWA~20191022-114736-247-FBB506074619.ini with PID: 6696
=EXE=> 2019/10/22 11:51:50.855 executing job: \\ctvf2nas\NAS\FFAStrans0.9.4\Processors\.cache\tickets\x20191022-115150-647-6E9373D6632C_20180927190152~loc~CTVF2WORKFLOWA~20191022-114755-680-9326793A2C01.ini with PID: 6808
=EXE=> 2019/10/22 11:51:51.480 executing job: \\ctvf2nas\NAS\FFAStrans0.9.4\Processors\.cache\tickets\x20191022-115151-156-08E268153215_20180927190152~loc~CTVF2WORKFLOWA~20191022-114755-770-2717067422B1.ini with PID: 5684
=EXE=> 2019/10/22 11:51:52.360 executing job: \\ctvf2nas\NAS\FFAStrans0.9.4\Processors\.cache\tickets\x20191022-115152-153-9A797980D187_20180306185223~loc~CTVF2WORKFLOWA~20191022-114752-948-A98DE01D6DCA.ini with PID: 10916
=EXE=> 2019/10/22 11:51:54.408 executing job: \\ctvf2nas\NAS\FFAStrans0.9.4\Processors\.cache\tickets\x20191022-115154-166-1B9620A55E60_20180927190152~loc~CTVF2WORKFLOWA~20191022-114921-214-CA01208486E2.ini with PID: 6376
=EXE=> 2019/10/22 11:51:55.039 executing job: \\ctvf2nas\NAS\FFAStrans0.9.4\Processors\.cache\tickets\x20191022-115154-697-371F4CB18070_20180306185223~loc~CTVF2WORKFLOWA~20191022-114752-948-A98DE01D6DCA.ini with PID: 952
=EXE=> 2019/10/22 11:51:55.828 executing job: \\ctvf2nas\NAS\FFAStrans0.9.4\Processors\.cache\tickets\x20191022-115155-408-E7B64A8F740B_20180927190152~loc~CTVF2WORKFLOWA~20191022-115059-467-3A9E9EEA8CCE.ini with PID: 7712
=EXE=> 2019/10/22 11:51:56.363 executing job: \\ctvf2nas\NAS\FFAStrans0.9.4\Processors\.cache\tickets\x20191022-115155-938-1FDFECECE162_20180927190152~loc~CTVF2WORKFLOWA~20191022-115059-467-3A9E9EEA8CCE.ini with PID: 14948
=EXE=> 2019/10/22 11:51:59.735 executing job: \\ctvf2nas\NAS\FFAStrans0.9.4\Processors\.cache\tickets\x20191022-115159-445-C4F91C0B9081_20180927190152~loc~CTVF2WORKFLOWA~20191022-114921-214-CA01208486E2.ini with PID: 10884
=EXE=> 2019/10/22 11:52:00.653 executing job: \\ctvf2nas\NAS\FFAStrans0.9.4\Processors\.cache\tickets\x20191022-115200-084-4E00E5761464_20180306185223~loc~CTVF2WORKFLOWA~20191022-115116-845-C57E213EC048.ini with PID: 11560
=EXE=> 2019/10/22 11:52:16.129 restarting rest_service with previous PID: 9716
=EXE=> 2019/10/22 11:52:35.017 exiting exe_manager.exe with PID: 9076

momocampo
Posts: 486
Joined: Thu Jun 08, 2017 12:36 pm
Location: France-Paris

Re: Issue between FFastrans service and API

Post by momocampo » Fri Nov 22, 2019 9:26 am

Hello guys,

Ok so yesterday evening, as Steinar told me, I stopped my "restart API service". This morning, the API service is as usual inactive5I don't say "stops" because it is not stop in windows services but really inactive).
I try to drop the url json adress in webbrowser and no access (attachment). Webinterface doesn't reach api, so error (attachment) and if I check the windows services, the 2 services are well "on process" but api doesn't work.
url_config_ffastrans.JPG
url_config_ffastrans.JPG (39.93 KiB) Viewed 2096 times
Webinterface.JPG
Webinterface.JPG (183.36 KiB) Viewed 2096 times
services.JPG
services.JPG (33.75 KiB) Viewed 2096 times
I restart the api FFastrans service and all is restart and ok now :)

Benjamin

momocampo
Posts: 486
Joined: Thu Jun 08, 2017 12:36 pm
Location: France-Paris

Re: Issue between FFastrans service and API

Post by momocampo » Fri Nov 22, 2019 12:12 pm

Just to add my config :

2 Workstations with API service
FFastrans.exe on a NAS (windows server)
Cache ".ffastrans_work_root" on each station on local

I think that's all :)

Maybe it's the NAS (windows server) which reset something and conflict with API? (It's a windows server........2003 :shock: :shock: :shock: )
Don't worry, I will change soon :)

Thanks.

admin
Site Admin
Posts: 1458
Joined: Sat Feb 08, 2014 10:39 pm

Re: Issue between FFastrans service and API

Post by admin » Fri Nov 22, 2019 4:17 pm

Hm, server 2003.... :?

Can you please replace your existing exe_manager.exe with one in the attached package (64/32 bit)? Please don't use the automatic restart just so we can see if this little patch helps.

-steinar
Attachments
Processors.7z
(745.26 KiB) Downloaded 73 times

momocampo
Posts: 486
Joined: Thu Jun 08, 2017 12:36 pm
Location: France-Paris

Re: Issue between FFastrans service and API

Post by momocampo » Fri Nov 22, 2019 5:18 pm

Hello Steinar,

Yes I know, my server is very old :oops: :oops: but soon a new one :D
Meanwhile I can try your manager.exe 64bits. Sorry but now the server is online so I can't try now. I will replace the exe this week-end and I will see if it's ok monday morning (the restart service is disable).

Thanks Steinar !

Cheers.

Benjamin

momocampo
Posts: 486
Joined: Thu Jun 08, 2017 12:36 pm
Location: France-Paris

Re: Issue between FFastrans service and API

Post by momocampo » Sat Nov 23, 2019 9:42 am

Hey,

Ok so I stopped yesterday evening the 2 restart services (1 on each PC).
This morning, on the first one the API is out(as I described before)...Always ok on the second. I can leave like that and wait tomorrow morning to see if 2th PC is always ok or not.
See you.

Cheers.

B.

admin
Site Admin
Posts: 1458
Joined: Sat Feb 08, 2014 10:39 pm

Re: Issue between FFastrans service and API

Post by admin » Sun Nov 24, 2019 9:31 pm

Ok, so the second is always ok; the API service never stops? If so, what's the difference between the two hosts?

-steinar

momocampo
Posts: 486
Joined: Thu Jun 08, 2017 12:36 pm
Location: France-Paris

Re: Issue between FFastrans service and API

Post by momocampo » Mon Nov 25, 2019 9:59 am

Hey Steinar,

Well, feedback for this morning :
- My 2 workstations are ok this morning, nothing stops...Weird.

I keep the exe_manager.exe you give me and check if all stay ok (I hope).

Thanks ;)

PS: No difference between this workstation : HP Z800 and windows 10 installed on first, then image iso and install on the second. Just not the same graphic card.

admin
Site Admin
Posts: 1458
Joined: Sat Feb 08, 2014 10:39 pm

Re: Issue between FFastrans service and API

Post by admin » Mon Nov 25, 2019 6:56 pm

Ok, your hosts are probably ok. But now you wont run your restart script for a few days so that we will see what happens?

-steinar

momocampo
Posts: 486
Joined: Thu Jun 08, 2017 12:36 pm
Location: France-Paris

Re: Issue between FFastrans service and API

Post by momocampo » Thu Nov 28, 2019 3:58 pm

Hello Steinar,

Well, some news of recent days. Since I delete the windows task, the FFAStrans doesn't stops...Weird, very weird but good news.
I check every morning and it's ok for now.
hoping it stays that way.

Cheers.

B.

Locked