Youtube problem and solution

Questions and answers on how to get the most out of FFAStrans
Post Reply
seePyou
Posts: 33
Joined: Tue Feb 07, 2017 2:54 pm

Youtube problem and solution

Post by seePyou » Thu Jul 04, 2019 1:06 am

Hello all,

so I tried to use the YouTube downloader with a workflow of Folder monitor -> YT decoder -> h264 -> folder delivery.
Nothing worked, errors were first "No video or audio found in media" when I was attempting to provide a YT URL instead of a file.
I then read up more and found that I can drag a link from the browser to a folder and I did so. The error was then "File does not contain any stream"

So the solution was the following:
search your system for "msvcr100.dll" and place it in the same folder as youtube-dl.exe (which is inside FFAStrans/processors/ffmpeg/)
launch command prompt
navigate to where the youtube-dl.exe is
type:
youtube-dl.exe -U

let it run. For me this is what happened:

c:\Utils\FFAStrans0.9.4\Processors\ffmpeg>youtube-dl.exe -U
Updating to version 2019.07.02 ...
Waiting for file handle to be closed ...

c:\Utils\FFAStrans0.9.4\Processors\ffmpeg>Updated youtube-dl to version 2019.07.02.
The batch file cannot be found.
The batch file cannot be found.

Now I could use this workflow with links dragged and dropped from the browser.

admin
Site Admin
Posts: 1276
Joined: Sat Feb 08, 2014 10:39 pm

Re: Youtube problem and solution

Post by admin » Thu Jul 04, 2019 5:56 pm

Hi seePyou,

I know about this shortcoming with the youtube-dl applications getting outdated. This will be addressed in the next major version of FFAStrans.

-steinar

seePyou
Posts: 33
Joined: Tue Feb 07, 2017 2:54 pm

Re: Youtube problem and solution

Post by seePyou » Thu Jul 04, 2019 9:48 pm

I expected nothing less, actually. You are great and this is a great product. I sound like an evangelist, but... Anyway. Great product, cannot recommend it enough!

Regards,
seePyou

Post Reply