"Got error code 80 - The file exists" on render farm

Questions and answers on how to get the most out of FFAStrans
Post Reply
GammaScorpii
Posts: 9
Joined: Fri Mar 01, 2019 12:11 pm

"Got error code 80 - The file exists" on render farm

Post by GammaScorpii » Mon Apr 22, 2019 11:42 pm

I have 2 machines running the application off a shared NAS drive.

Everything works fine, the application seems to be able to split the workload between my 2 PCs, but about 1 in 20 jobs fail with the error:

Job ended with error on Folder@PC1: Got error code 80 - The file exists, when trying to deliver "\\192.168.0.100\Cards\AACC-KIDZ-19042019-B02_Proxy\C0128_Proxy.mov"

Seems to be running some jobs on both systems. Is this something that can be avoided? Or is it just a caveat of running a render farm that some jobs start at the same time and don't cancel the other one?

Thanks.

admin
Site Admin
Posts: 1252
Joined: Sat Feb 08, 2014 10:39 pm

Re: "Got error code 80 - The file exists" on render farm

Post by admin » Tue Apr 23, 2019 10:23 am

Hi GammaScorpii,

Are you running Win7/Serv2008 or less?

-steinar

GammaScorpii
Posts: 9
Joined: Fri Mar 01, 2019 12:11 pm

Re: "Got error code 80 - The file exists" on render farm

Post by GammaScorpii » Mon May 13, 2019 1:38 am

Hi steinar,

No both machines are running Windows 10 Home. Should be up to date.

emcodem
Posts: 369
Joined: Wed Sep 19, 2018 8:11 am

Re: "Got error code 80 - The file exists" on render farm

Post by emcodem » Tue May 14, 2019 7:11 am

Hey there!

the shared location where you have your ffastrans installation files, what kind of storage is it? Did you create a share on a standard windows server or is it a dedicated NAS storage like ISILON etc...?

cheers,
Harry

GammaScorpii
Posts: 9
Joined: Fri Mar 01, 2019 12:11 pm

Re: "Got error code 80 - The file exists" on render farm

Post by GammaScorpii » Mon Jul 15, 2019 11:40 am

Installation files are stored on a shared USB 3 external SSD in a Synology DS1515+. Shared over SMB obviosuly.

File system (i believe) is btrfs.

emcodem
Posts: 369
Joined: Wed Sep 19, 2018 8:11 am

Re: "Got error code 80 - The file exists" on render farm

Post by emcodem » Mon Jul 15, 2019 1:29 pm

Hi there,
as there is currently another case running with ThomasM viewtopic.php?f=5&t=899 about the shared files (especially the cache directory) residing on a Synology drive, i'd recommend to configure the share to somewhere else than that storage. It is just shots into the dark butt currently i suspect the smb config of synology (or even deeper problem) to cause troubles with the simultanous file access to the internal .ini files that is done from the independent ffastrans nodes.

For the case that it really looks like a node is executed on multiple systems at the same time, the only thing i can currently recommend is to use a shared drive on a windows machine. In case we find some solution for the problem in the other case, i'd update this one too.

cheers!

Post Reply