New user experience (in steps)

Questions and answers on how to get the most out of FFAStrans
seePyou
Posts: 33
Joined: Tue Feb 07, 2017 2:54 pm

New user experience (in steps)

Post by seePyou » Tue Feb 07, 2017 3:02 pm

Cannot believe that such a software exists out here for free! I will be definitely be considering donating after I get my feet wet with it. So far I have just discovered the software's existence, and I will be trying to use it later at home.
My workflow will be to monitor one folder for a .ts video file, split it into DNxHD145 (or greater) and a .wav audio file (both files in the same folder but different to the first watchfolder obv.), edit the .wav in Audacity. Edit from there, and finally export the DNxHD video file to a third folder where FFAStrans will make it an H.264.
No idea how easy this all will be to setup, but I'll let you know :)

seePyou
Posts: 33
Joined: Tue Feb 07, 2017 2:54 pm

Re: New user experience (in steps)

Post by seePyou » Tue Feb 07, 2017 7:49 pm

I downloaded the latest version from the site. 0.7.7, and extracted it into a folder for it and run it. Messed about a little with workflows and did things wrong, but I ended up with one that was OK and running. Only nothing happened. So I checked what was going on, and ended up discovering that although I had blocked Windows Defender, Avast was in silent mode and was blocking the two known programs: exe_manager and def_runner
so I disabled it now and copied them too (unzip the entire thing again and overwrite) and run FFAStrans again. But it just sat there, doing nothing, and the exe_manager and def_runner were still not running in Task Manager.
So I'm stuck :)
Help ?

seePyou
Posts: 33
Joined: Tue Feb 07, 2017 2:54 pm

Re: New user experience (in steps)

Post by seePyou » Thu Feb 09, 2017 10:06 am

Help!? Please?

All I have is a simple Monitor Folder for *.mp4|*.ts, leading to an encoder for DNxHD 145, which leads to a delivery folder.

The monitored folder is a network share the computer and user have access to as well as read/write privileges, and has two video files in it, one a H.264 .mp4 file and one is a MPEG/AVC .ts file.

Nothing is happening, workflows are started, monitor just sits there empty.
Help?!

admin
Site Admin
Posts: 1303
Joined: Sat Feb 08, 2014 10:39 pm

Re: New user experience (in steps)

Post by admin » Thu Feb 09, 2017 12:51 pm

Hi seePyou, thank you for trying to use FFAStrans and welcome to the forum! ;-)

Please double check again that your AV's are NOT stopping the def_runner and and exe_manger. Also, in worst case scenario try and remove them totaly. You might want to temporary disconnect from you network while doing that, just to be on the safe side.

-steinar

seePyou
Posts: 33
Joined: Tue Feb 07, 2017 2:54 pm

Re: New user experience (in steps)

Post by seePyou » Fri Feb 10, 2017 10:24 am

Hello Steinar,

no, nothing is blocking them now. There is no extra av/scanning software on this computer, all the MS parts are deactivated or disabled (firewall, defender) and no AV in my network is scanning in the network.
The def_runner and exe_manager are still in the folder where they should be, and nothing has removed it yet, since last night. I am running the ffastrans.exe normally, and as admin, but it doesn't change the behaviour.

admin
Site Admin
Posts: 1303
Joined: Sat Feb 08, 2014 10:39 pm

Re: New user experience (in steps)

Post by admin » Tue Feb 14, 2017 7:59 pm

Have you tried to submit jobs manually?

-steinar

seePyou
Posts: 33
Joined: Tue Feb 07, 2017 2:54 pm

Re: New user experience (in steps)

Post by seePyou » Wed Feb 15, 2017 7:38 am

Right click on the watchfoler, submit file, select an appropriate file for it and wait. 10 minutes later, nothing has happened.

Image

Image

Image

Image

seePyou
Posts: 33
Joined: Tue Feb 07, 2017 2:54 pm

Re: New user experience (in steps)

Post by seePyou » Wed Feb 15, 2017 7:55 am

I keep amassing evidence of my stupidity online...

it works, I had just packed it in a nested folder and of course the two programs it needed were not found where it expected them.

Anyway, the mp4 to mxf workflow work fine, but now I have another problem.

Image

This is an mpeg/avc video file, acceptable by handbrake for example. The purpose of my intended workflow is to automate the transcode away from handbrake.

Image

Any idea what I'm missing here?

seePyou
Posts: 33
Joined: Tue Feb 07, 2017 2:54 pm

Re: New user experience (in steps)

Post by seePyou » Wed Feb 15, 2017 8:14 am

Problem 2: when the transcoding finished for the .mp4 file, another started.

Image

How do I prevent this?

admin
Site Admin
Posts: 1303
Joined: Sat Feb 08, 2014 10:39 pm

Re: New user experience (in steps)

Post by admin » Wed Feb 15, 2017 10:40 pm

Does this double transcoding happen all the time or is it just one freak accident?
I don't suppose you could send me the .ts file that failed so I can investigate?

-steinar

Post Reply