Watermark

Questions and answers on how to get the most out of FFAStrans
Post Reply
vijm1972
Posts: 128
Joined: Fri Apr 24, 2015 7:35 am

Watermark

Post by vijm1972 » Sun Aug 21, 2016 10:46 am

Hi,

Please let me know how to locate .png watermark source location. My .png file is in shared storage location, I am trying below command but it's getting failed.

-c:v libx264 -preset veryslow -crf 18 -s 640x360 -aspect 16:9 -b:v 650000 -minrate 650000 -maxrate 650000 -bufsize 650000 -pix_fmt yuv420p -coder 1 -flags +loop -cmp chroma -partitions +parti8x8+parti4x4+partp8x8+partb8x8 -me_method 4 -subq 6 -me_range 16 -g 15 -keyint_min 1 -bf 0 -intra -refs 4 -sc_threshold 40 -i_qfactor 0.71 -b_strategy 1 -qcomp 0.6 -qmin 10 -qmax 51 -qdiff 4 -direct-pred 1 -fast-pskip 1 -vprofile main -vlevel 4.1 -movflags +faststart -c:a aac -ar 48000 -b:a 128000 -ac 2 -filter_complex "[0:1] [0:2] amerge" -vf "movie='\\tnc1.pfin.com\Techtest\FFMPEG\Logo\HDFINAL.png',scale=1920:1080[over];[in][over]overlay=0:0,drawtext=fontfile=/Windows/Fonts/arial.ttf:fontsize=80:x=700:y=900:box=1:boxcolor=black@0.5:rate='24000/1001':fontcolor=white:timecode='00\:00\:00\:00"

Can you please suggest how can I mention shared storage location of watermark. Watermark source location is \\tnc1.pfin.com\Techtest\FFMPEG\Logo\HDFINAL.png

If I used same command using local watermark path I am getting output without any error.

Thanks,
Vijay

admin
Site Admin
Posts: 1276
Joined: Sat Feb 08, 2014 10:39 pm

Re: Watermark

Post by admin » Sun Aug 21, 2016 3:49 pm

When using paths in ffmpeg filters, you need to escape all "\" and ":" characters with a "\". So you get the following command:

-c:v libx264 -preset veryslow -crf 18 -s 640x360 -aspect 16:9 -b:v 650000 -minrate 650000 -maxrate 650000 -bufsize 650000 -pix_fmt yuv420p -coder 1 -flags +loop -cmp chroma -partitions +parti8x8+parti4x4+partp8x8+partb8x8 -me_method 4 -subq 6 -me_range 16 -g 15 -keyint_min 1 -bf 0 -intra -refs 4 -sc_threshold 40 -i_qfactor 0.71 -b_strategy 1 -qcomp 0.6 -qmin 10 -qmax 51 -qdiff 4 -direct-pred 1 -fast-pskip 1 -vprofile main -vlevel 4.1 -movflags +faststart -c:a aac -ar 48000 -b:a 128000 -ac 2 -filter_complex "[0:1] [0:2] amerge" -vf "movie='\\\\tnc1.pfin.com\\Techtest\\FFMPEG\\Logo\\HDFINAL.png',scale=1920:1080[over];[in][over]overlay=0:0,drawtext=fontfile='C\:\\Windows\\Fonts\\arial.ttf':fontsize=80:x=700:y=900:box=1:boxcolor=black@0.5:rate='24000/1001':fontcolor=white:timecode='00\:00\:00\:00"

Try it out.

-steinar

vijm1972
Posts: 128
Joined: Fri Apr 24, 2015 7:35 am

Re: Watermark

Post by vijm1972 » Mon Aug 22, 2016 12:01 pm

Thanks Steinar it's working perfectly.

Post Reply